nixos-config/machines/usbstick/hardware-configuration/disko-config.nix
Ingolf Wagner 848eccb959
All checks were successful
Build all NixOS Configurations / nix build (push) Successful in 10m19s
made usbstick work again
2024-08-09 02:45:22 +02:00

45 lines
1,004 B
Nix

# Example to create a bios compatible gpt partition
{ lib, ... }:
{
disko.devices = {
disk.disk1 = {
device = lib.mkDefault "/dev/sda";
type = "disk";
content = {
type = "gpt";
partitions = {
boot = {
name = "boot";
size = "1M";
type = "EF02";
};
esp = {
name = "ESP";
size = "500M";
type = "EF00";
content = {
type = "filesystem";
format = "vfat";
mountpoint = "/boot";
};
};
root = {
name = "root";
size = "100%";
content = {
type = "luks";
name = "root";
settings.allowDiscards = true;
content = {
type = "filesystem";
format = "ext4";
mountpoint = "/";
};
};
};
};
};
};
};
}