nixos-config/machines/orbi/hardware-configuration/default.nix
Ingolf Wagner f411567ad6
All checks were successful
Build all NixOS Configurations / nix build (push) Successful in 9m21s
refactor hardware/hetzner.nix
2024-08-08 00:14:52 +02:00

30 lines
858 B
Nix

{ config, pkgs, modulesPath, lib, factsGenerator, ... }:
{
system.stateVersion = "23.11";
imports = [
./disko-config.nix
./hardware-configuration.nix
./hetzner.nix
];
services.smartd.enable = true;
# root password
clan.core.facts.services.rootPassword = factsGenerator.password { name = "root"; };
users.users.root.hashedPasswordFile = config.clan.core.facts.services.rootPassword.secret."password.root.pam".path;
# todo : use component for that
services.openssh.settings.PermitRootLogin = "prohibit-password";
services.openssh.settings.PasswordAuthentication = false;
boot.tmp.useTmpfs = true; # make /tmp a tmpfs (performance!)
boot.supportedFilesystems = [ "zfs" ];
clan.core.facts.services.zfs = factsGenerator.zfs { };
networking.hostId = config.clan.core.facts.services.zfs.public."zfs.hostId".value;
}