nixos-config/features/network/sshguard.nix
Ingolf Wagner 26aaec9101
All checks were successful
Build all NixOS Configurations / nix build (push) Successful in 12m39s
fixing fail2ban and set up ssh + tor on chungus
2024-08-08 19:25:19 +02:00

19 lines
332 B
Nix

{ pkgs, config, lib, assets, ... }:
with lib;
with types;
{
options.features.network.sshguard = {
enable = mkOption {
type = bool;
default = false;
};
};
config = mkIf config.features.network.sshguard.enable {
environment.systemPackages = [ pkgs.ipset ];
services.sshguard.enable = true;
};
}