nixos-config/components/terminal/default.nix
Ingolf Wagner 161486b887
Some checks failed
Build all NixOS Configurations / nix build (push) Failing after 6s
fix fonts and oh-my-posh
2024-08-11 21:09:53 +02:00

30 lines
522 B
Nix

{ config, pkgs, lib, ... }:
with lib;
{
options.components.terminal = {
enable = mkOption {
type = types.bool;
default = true;
};
};
imports = [
./direnv.nix
./git.nix
./heygpt.nix
./hoard.nix
./remote-install.nix
./wtf.nix
./zsh.nix
];
config = mkIf config.components.terminal.enable {
environment.systemPackages = [
pkgs.ranger # datei browser
pkgs.retry # retry command till success
pkgs.silver-searcher
pkgs.treefmt
];
};
}