nixos-config/components/gui/default.nix
Ingolf Wagner 161486b887
Some checks failed
Build all NixOS Configurations / nix build (push) Failing after 6s
fix fonts and oh-my-posh
2024-08-11 21:09:53 +02:00

31 lines
669 B
Nix

{ pkgs, lib, config, ... }:
with lib;
{
options.components.gui = {
enable = lib.mkEnableOption "GUI configurations";
};
imports = [
# todo : structure with home-manager and such is not cool, create another structure
./audio.nix
./browser.nix
./cups.nix
./home-manager
./kmonad.nix
#./noti.nix # todo: make this different (use password store and such)
./pass.nix
./steam.nix
./suspend.nix
./vscode.nix
./wayland.nix
./xorg
];
config = mkIf config.components.gui.enable {
# todo extract xorg stuff to prepare wayland
environment.enableAllTerminfo = true;
qt.platformTheme = "qt5ct";
};
}