nixos-config/components/gui/wayland.nix

14 lines
307 B
Nix

{ config, pkgs, lib, ... }:
with lib;
{
options.components.gui.wayland.enable = mkOption {
type = lib.types.bool;
default = !config.components.gui.xorg.enable;
};
config = mkIf (config.components.gui.wayland.enable && config.components.gui.enable) {
programs.sway.enable = false;
};
}