nixos-config/machines/orbi/service-forgejo.nix
Ingolf Wagner e43f4514bc
All checks were successful
Build all NixOS Configurations / nix build (push) Successful in 12m40s
create verify.http options
2024-09-16 07:06:03 +07:00

44 lines
896 B
Nix

{
config,
lib,
pkgs,
...
}:
{
verify.http.forgejjo = {
url = "https://git.ingolf-wagner.de/explore/repos";
expectedContent = "palo/nixos-config";
};
services.nginx = {
enable = true;
statusPage = true;
virtualHosts = {
"git.ingolf-wagner.de" = {
forceSSL = true;
enableACME = true;
locations."/" = {
proxyPass = "http://localhost:${toString config.services.forgejo.settings.server.HTTP_PORT}";
};
};
};
};
services.forgejo = {
enable = true;
settings = {
server.ROOT_URL = "https://git.ingolf-wagner.de/";
server.DOMAIN = "git.ingolf-wagner.de";
DEFAULT.APP_NAME = "git.ingolf-wagner.de";
service.DISABLE_REGISTRATION = true;
session.COOKIE_SECURE = true;
log.LEVEL = "Warn";
other = {
SHOW_FOOTER_VERSION = false;
};
};
};
}