{ pkgs, ... }:
let
  port = 9001;
in
{

  healthchecks.http.wastebin = {
    url = "https://paste.ingolf-wagner.de";
    expectedContent = "open";
  };

  services.wastebin = {
    enable = true;
    settings = {
      WASTEBIN_ADDRESS_PORT = "127.0.0.1:${toString port}";
      WASTEBIN_TITLE = "paste.ingolf-wagner.de";
      WASTEBIN_MAX_PASTE_EXPIRATION = 60 * 60 * 24 * 30;
    };
  };

  services.nginx = {
    enable = true;
    virtualHosts."paste.ingolf-wagner.de" = {
      forceSSL = true;
      enableACME = true;
      locations."/" = {
        recommendedProxySettings = true;
        proxyWebsockets = true;
        proxyPass = "http://127.0.0.1:${toString port}";
      };
    };
  };
}