{
  config,
  lib,
  pkgs,
  ...
}:
with lib;
{

  options.components.chaospott.enable = mkOption {
    type = lib.types.bool;
    default = config.components.gui.enable;
  };

  config = mkIf (config.components.chaospott.enable && config.components.gui.audio.enable) {
    hardware.pulseaudio.zeroconf.discovery.enable = true;
    environment.systemPackages = with pkgs; [
      paprefs
    ];
  };
}